  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.heraldextra.com/content/tncms/live/" />
<meta name="keywords" content="brandon averette, mark madsen, coach, mark pope, sport, basketball, dan nielson" />
<meta name="news_keywords" content="brandon averette, mark madsen, coach, mark pope, sport, basketball, dan nielson" />
<meta name="description" content="It&rsquo;s been 581 days since Brandon Averette played in an actual college basketball game." />
<meta name="author" content="Darnell Dickson Daily Herald" />
<meta property="article:author" content="https://www.facebook.com/Darnell-Dickson-768466646546122/" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=899795400" />
<meta name="google-play-app" content="app-id=com.heraldextra.SportsStatsMobile.College" />
<meta name="google-site-verification" content="WoEafqqsKsMGeYxoXXPetRK4ZAkZDz56fXtPuSJTiBg" />
<meta name="p:domain_verify" content="cea7e8c847d5dbadf65a6ffa6156b1b4" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=945%2C630" />
<meta property="og:image:width" content="945" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Averette's wait is almost over as UVU basketball season approaches" />
<meta property="og:description" content="It&rsquo;s been 581 days since Brandon Averette played in an actual college basketball game." />
<meta property="og:site_name" content="Daily Herald" />
<meta property="og:section" content="UVU Men's Basketball" />
<meta property="fb:app_id" content="223859437624341" />
<meta property="article:publisher" content="http://www.heraldextra.com/utahvalleydailyherald" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@heraldextra" />
<meta name="twitter:creator" content="@http://www.twitter.com/darnellwrites" />
<meta name="twitter:image:alt" content="Brandon Averette UVU mbb media day" />
<meta name="twt-site-id" content="000001587956b995_2a5f1c1" />
<meta name="twt-article-id" content="8f580909-f0b1-508c-9759-b3b7f4474926" />
<meta name="twt-author-name" content="ddickson@heraldextra.com" />
<link rel="manifest" href="/tncms/messaging/manifest/" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.ddf99fc6264d54348455c6d92dcf2a29.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.ade97bff71085cf8bd66a04d01c0c078.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Hind:400,700,500|Open+Sans:400,400italic,700,700italic"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-notification-controls.59c1d0c5e246ea47a3e98ddd63643d10.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/styles/owl.carousel.d631cca58a0d014854c4a6c1815f1da3.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.150.0"},"page":{"grid":"pattern","style":"default","path":"\/sports\/college\/uvu\/basketball-men","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Darnell Dickson\nDaily Herald"},"vendor":{"outbrain":"disabled","taboola":"","chartbeat":"80407"},"system":{"render_time":304},"client":{"is_bot":"no","is_gdpr":"no"}},"chartbeat":"80407","taxonomy_1":"sports","taxonomy_2":"college","taxonomy_3":"uvu","taxonomy_4":"basketball-men","taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"heraldextra.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"sports","blox_sections":"sports,college,uvu,basketball-men","weather_temp":38,"weather_conditions":"Sunny","asset_source":"local","blox_asset_type":"article","asset_section":"sports\/college\/uvu\/basketball-men","asset_id":"8f580909-f0b1-508c-9759-b3b7f4474926","asset_headline":"Averette's wait is almost over as UVU basketball season approaches","asset_byline":"By Darnell Dickson\nDaily Herald\n","asset_pub_date":"10\/24\/2019","asset_pub_time":"5:45 am","asset_canonical":"https:\/\/www.heraldextra.com\/sports\/college\/uvu\/basketball-men\/averette-s-wait-is-almost-over-as-uvu-basketball-season\/article_8f580909-f0b1-508c-9759-b3b7f4474926.html","asset_tag_1":"brandon averette","asset_tag_2":"mark madsen","asset_tag_3":"coach","asset_tag_4":"mark pope","asset_tag_5":"sport","asset_tag_6":"basketball","asset_tag_7":"dan nielson","asset_flag_1":"editors_pick"});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.2298fa2c06ac9b301ef502070168c6dc.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.42d7d95b5ff2ee2929df2da8d9813233.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.1a43ae64e3ee8be134e1d98df60265ff.js"></script>
<script>/*<![CDATA[*/ (function(d,w){
        if(w.navigator.userAgent.indexOf('Trident/') > 0){
            d.write('<scr'+'ipt '+'src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator">'+'\x3C/scr'+'ipt>');
        }
    }(document,window)); /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://app.worldtable.co/the-world-table.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.6e1ca8839e8a715fdecb1c734223823a.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.notify.panel.d88d0bab7146734def61a46ceda12622.js"></script>
<!--[gte IE 17]><!--><script src="https://www.gstatic.com/firebasejs/6.0.0/firebase-app.js" defer="defer"></script><!--<![endif]-->
<!--[gte IE 17]><!--><script src="https://www.gstatic.com/firebasejs/6.0.0/firebase-messaging.js" defer="defer"></script><!--<![endif]-->
<!--[gte IE 17]><!--><script src="/shared-content/art/tncms/api/messaging.js" defer="defer"></script><!--<![endif]-->
<!--[gte IE 17]><!--><script>/*<![CDATA[*/ document.addEventListener('DOMContentLoaded', function() {TNCMS.Messaging.init({messagingSenderId: '231882495886'});TNCMS.Messaging.onMessage(messagingCallback);}); /*]]>*/</script><!--<![endif]-->
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>

            
            <title>Averette's wait is almost over as UVU basketball season approaches | UVU Men's Basketball | heraldextra.com</title>
            
    <style>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</style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.heraldextra.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/9bdcbc24-0b44-11e7-b908-4f6f8ebddf23.png?crop=23%2C23%2C26%2C0&resize=180%2C180&order=crop%2Cresize" />
    
        <link rel="amphtml" href="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.amp.html" />
    
        <link rel="dns-prefetch preconnect" href="//www.google.com">
    
        <link rel="dns-prefetch preconnect" href="//adservice.google.com">
    
        <link rel="dns-prefetch preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="dns-prefetch preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="dns-prefetch preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="dns-prefetch preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="dns-prefetch preconnect" href="//www.googletagmanager.com">
    
        <link rel="dns-prefetch preconnect" href="//www.google-analytics.com">
    
        <link rel="dns-prefetch preconnect" href="//app.worldtable.co">
    <link rel="alternate" type="application/rss+xml" title="Averette's wait is almost over as UVU basketball season approaches | UVU Men's Basketball | heraldextra.com" href="http://www.heraldextra.com/search/?f=rss&amp;t=article&amp;c=sports/college/uvu/basketball-men&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.af332b041a70998e9926bdcdd7fefe67.js"></script>
              

	<script type='text/javascript'>
		var googletag = googletag || {};
		googletag.cmd = googletag.cmd || [];
		(function() {
			var gads = document.createElement('script');
			gads.async = true;
			gads.type = 'text/javascript';
			var useSSL = 'https:' == document.location.protocol;
			gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
			var node = document.getElementsByTagName('script')[0];
			node.parentNode.insertBefore(gads, node);
		})();
	</script>


        <script type='text/javascript'>

                /* get the main category to use for the MSection variable */
                var root_path = unescape(document.location.pathname);
                root_path.indexOf(1);			
                root_path.toLowerCase();				
                root_path = root_path.split("/")[1];
                var root_path = '/' + root_path;
                var root_path = root_path.replace(/[^a-z0-9\/]|\s+|\r?\n|\r/gmi, "_");
                if ( root_path == '/' ) {
                    root_path = '/homepage';
                }

                /* full_path comes from a TownNews provided variable */
                var full_path = '/sports/college/uvu/basketball-men';
                if ( full_path == '/' ) {
                    full_path = '/homepage';
                }


                console.log("MSection = " + root_path);
                console.log("SubSection = " + full_path);



                googletag.cmd.push(function() {
			googletag.pubads().setTargeting('SiteID','DHPU'); 		/* Define in Functions */
			googletag.pubads().setTargeting('MSection',root_path); 	/* top lvl parent */
			googletag.pubads().setTargeting('SubSection',full_path); 	/* current lvl parent */
		});
	</script>

	<script type='text/javascript'>
		googletag.cmd.push(function() {

			var Leaderboard = googletag.sizeMapping().
			addSize([1130, 200], [[970, 250], [728, 90]]).
                        addSize([320, 0], [[320, 100], [1, 1]]). //mobile
			addSize([0, 0], [320, 100]).
			build();


			var BottomLeaderboard = googletag.sizeMapping().
			addSize([740, 200], [728, 90]).
			addSize([0, 0], [320, 100]).
			build();

			var SkyScraper = googletag.sizeMapping().
			addSize([1406, 200], [160, 600]).
			addSize([1335, 200], [120, 600]).
			addSize([0, 0], []).
			build();

			var HalfPage = googletag.sizeMapping().
			addSize([740, 200], [300, 600]).
			addSize([0, 0], [300, 250]).
			build();
			
			var Pencil = googletag.sizeMapping().
			addSize([960, 200], [960, 250]).
                        addSize([320, 0], [[320, 50], [320, 100], [320, 200], [300, 250], [1, 1]]). //mobile
			addSize([0, 0], []).
			build();
			

			googletag.pubads().addEventListener('slotRenderEnded', function(event) {
				/*console.log(event.slot.getAdUnitPath() + ' - position is blank?: ' + event.isEmpty + ' - lineItemID: ' + event.lineItemId + ' - creativeId: ' + event.creativeId + ' - campaignId: ' + event.campaignId);*/
                                var ad_position = event.slot.getAdUnitPath().split("/");
                                var ad_position = ad_position[ad_position.length-1];
 				if (event.isEmpty) {
                                    document.getElementById(ad_position).style.display = 'none';
				}
			});


			googletag.defineSlot('/1032081/Pro_Top_728x90', [728, 90], 'Pro_Top_728x90').
			defineSizeMapping(Leaderboard).
			addService(googletag.pubads());

			googletag.defineSlot('/1032081/PRO_Bottom_728x90', [728, 90], 'PRO_Bottom_728x90').addService(googletag.pubads()).
			defineSizeMapping(BottomLeaderboard).
			addService(googletag.pubads());

			googletag.defineSlot('/1032081/PRO_1x1', [1, 1], 'PRO_1x1').addService(googletag.pubads());
			googletag.defineSlot('/1032081/PRO_Bottom_1x1', [1, 1], 'PRO_Bottom_1x1').addService(googletag.pubads());
			googletag.defineSlot('/1032081/PRO_Top_1x1', [1, 1], 'PRO_Top_1x1').addService(googletag.pubads());
			googletag.defineSlot('/1032081/PRO_Middle1_300x250', [300, 250], 'PRO_Middle1_300x250').addService(googletag.pubads());
			googletag.defineSlot('/1032081/PRO_Middle2_300x250', [300, 250], 'PRO_Middle2_300x250').addService(googletag.pubads());
			googletag.defineSlot('/1032081/PRO_Middle3_300x250', [300, 250], 'PRO_Middle3_300x250').addService(googletag.pubads());                        
			googletag.pubads().enableSingleRequest();
			googletag.enableServices();
		});
	</script>


        <script type="text/javascript">
          /* dataLayer.push({
              'event':'VirtualPageview',
              'virtualPageURL': tncms.event_virtual_pageview.url,
              'virtualPageTitle': "Averette's wait is almost over as UVU basketball season approaches | UVU Men's Basketball | heraldextra.com"
            }); */
        </script>


    <div id="PRO_Top_1x1" style="text-align:center">
        <script>
            googletag.cmd.push(function() { googletag.display('PRO_Top_1x1'); });
        </script>
    </div><script language="javascript" type="text/javascript">
        $(document).ready(function() {     
              $("body.section-users .user-register-wrapper .panel-footer.user-signup").html("<p><i class='fas tnt-user'></i> Already have an account? <a href='https://www.heraldextra.com/users/login/?referer_url=/'>Log in here</a></p>");  
             
         }); 
    </script>
  



  

        </head>
        <body class="fixed-scroll-nav app-editorial blox-asset uuid-8f580909-f0b1-508c-9759-b3b7f4474926 section-sportssection-collegesection-uvusection-basketball-men type-article infinity-disabled" data-authors='[]'>
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.heraldextra.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.150.0&tncms.page.grid=pattern&tncms.page.style=default&tncms.page.path=%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.asset.author=Darnell+Dickson%0ADaily+Herald&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.vendor.chartbeat=80407&tncms.system.render_time=304&tncms.client.is_bot=no&tncms.client.is_gdpr=no&chartbeat=80407&taxonomy_1=sports&taxonomy_2=college&taxonomy_3=uvu&taxonomy_4=basketball-men&blox_platform=desktop&blox_page_type=asset&blox_domain=heraldextra.com&blox_skin=flex-editorial&blox_application=editorial&groups.content=1&groups.advertising=2&groups.utility=3&content_group=1&content_group_id=sports&blox_sections=sports%2Ccollege%2Cuvu%2Cbasketball-men&weather_temp=38&weather_conditions=Sunny&asset_source=local&blox_asset_type=article&asset_section=sports%2Fcollege%2Fuvu%2Fbasketball-men&asset_id=8f580909-f0b1-508c-9759-b3b7f4474926&asset_headline=Averette%27s+wait+is+almost+over+as+UVU+basketball+season+approaches&asset_byline=By+Darnell+Dickson%0ADaily+Herald%0A&asset_pub_date=10%2F24%2F2019&asset_pub_time=5%3A45+am&asset_canonical=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html&asset_tag_1=brandon+averette&asset_tag_2=mark+madsen&asset_tag_3=coach&asset_tag_4=mark+pope&asset_tag_5=sport&asset_tag_6=basketball&asset_tag_7=dan+nielson&asset_flag_1=editors_pick&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        <!-- Google Tag Manager -->
        <script>
            var dataLayer = window.dataLayer || [];
            dataLayer.push(
                {'user_id': __tnt.user.screenName},
                {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                {'utm_label': __tnt.urlHash('utm_label')}
            );
        </script>
        <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WC4KGXJ" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <script>
            (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
            new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
            j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
            '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-WC4KGXJ');
        </script>
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-edit-container-8f580909-f0b1-508c-9759-b3b7f4474926" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fas tnt-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this article.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://www.heraldextra.com/users/admin/contribute/article/?assetid=8f580909-f0b1-508c-9759-b3b7f4474926&assettype=article"><i class="fas tnt-pen-square"></i> Edit Article</a>
                    
                        <a class="btn btn-danger" href="https://www.heraldextra.com/users/admin/contribute/article/?from_section=/sports/college/uvu/basketball-men"><i class="fas tnt-plus-square"></i> Add New Article</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div>

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left  visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1367852" class="tncms-block site-brand-mark"><div id="site-logo-1367852" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/954024a2-0813-11e7-93c9-33966db84f65.png?resize=200%2C200" 
            srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/954024a2-0813-11e7-93c9-33966db84f65.png?resize=200%2C200 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/954024a2-0813-11e7-93c9-33966db84f65.png 300w"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-1367848" class="tncms-block site-follow-us"><div class="follow-links-1367848 default">
    
    <section id="block-1367848" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/UtahValleyDailyHerald" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://www.twitter.com/heraldextra" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="http://www.youtube.com/dailyherald" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://www.pinterest.com/dailyherald" title="Pinterest" target="_blank" rel="noopener" class="btn btn-xs btn-link pt">
                    <i class="fab tnt-pinterest"></i>
                    <span class="sr-only">Pinterest</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.instagram.com/dailyheraldutah/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.heraldextra.com",
  "sameAs" : ["https://www.facebook.com/UtahValleyDailyHerald","http://www.twitter.com/heraldextra","http://www.youtube.com/dailyherald","http://www.pinterest.com/dailyherald","https://www.instagram.com/dailyheraldutah/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1368913" class="tncms-block"><div id="user-controls-1368913" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.heraldextra.com/users/signup/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.heraldextra.com/users/login/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" class="btn btn-default btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.heraldextra.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1368913').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.heraldextra.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.heraldextra.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.heraldextra.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1368913').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.heraldextra.com/users/logout/" id="user-logout-form-1368913"><input type="hidden" name="referer_url" value="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1382936" class="tncms-block"><br><center>
<a href="http://www.heraldextra.com/subscribenow/"><h4>Subscribe</h4></a>
</center>
<div class="media-body">
<center>
<a href="http://www.heraldextra.com/subscribenow/"><button type="button" class="btn btn-primary btn-xs">Subscriber Services</button></a>

<a href="http://www.heraldextra.com/e-edition"><button type="button" class="btn btn-primary btn-xs">E-edition</button></a>
</center>
</div>
<br></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/business/local/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a href="/news/local/faith/"  class="nav-link tnt-section-faith">Faith</a>
                                </li><li>
                                    <a href="/news/local/crime-and-courts/"  class="nav-link tnt-section-crime">Crime</a>
                                </li><li>
                                    <a href="/news/community/"  class="nav-link tnt-section-community">Community</a>
                                </li><li>
                                    <a href="/gallery"  class="nav-link tnt-section-photos">Photos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/sports"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/high-school"  class="nav-link tnt-section-high-school">High School</a>
                                </li><li>
                                    <a href="/sports/college/byu/"  class="nav-link tnt-section-cougarblue">Cougarblue</a>
                                </li><li>
                                    <a href="/sports/college/uvu/"  class="nav-link tnt-section-uvu">UVU</a>
                                </li><li>
                                    <a href="/sports/basketball/professional/"  class="nav-link tnt-section-utah-jazznba">Utah Jazz/NBA</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/news/opinion"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/news/opinion/mailbag/"  class="nav-link tnt-section-letters">Letters</a>
                                </li><li>
                                    <a href="/news/opinion/herald-editorials/"  class="nav-link tnt-section-herald-editorials">Herald Editorials</a>
                                </li><li>
                                    <a href="https://heraldextra.com/forms/online_services/submit_letter/submit_a_letter_to_the_editor"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-a-letter">Submit a Letter</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/entertainment"  class="nav-link tnt-section-life-entertainment">Life & Entertainment</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/entertainment"  class="nav-link tnt-section-the-ticket">The Ticket</a>
                                </li><li>
                                    <a href="/momclick/"  class="nav-link tnt-section-mom-click">Mom Click</a>
                                </li><li>
                                    <a href="/lifestyles/announcements"  class="nav-link tnt-section-celebrations">Celebrations</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/calendar"  class="nav-link tnt-section-events-calendar">Events Calendar</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/special-section"  class="nav-link tnt-section-special-sections">Special Sections</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/lifestyles/announcements/obituaries"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/bestof"  class="nav-link tnt-section-best-of-utah-valley">Best of Utah Valley</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-9" data-target="#mobile-nav-left_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/ads/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/homes"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a href="http://jobs.heraldextra.com"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                                </li><li>
                                    <a href="/dealoftheday"  class="nav-link tnt-section-deals">Deals</a>
                                </li><li>
                                    <a href="/places/"  class="nav-link tnt-section-business-directory">Business Directory</a>
                                </li><li>
                                    <a href="/ads/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                                </li><li>
                                    <a href="http://circulars.heraldextra.com/?utm_source=heraldextra&amp;utm_medium=ham_menu&amp;utm_content=circ&amp;utm_campaign=lee_circ"  target="_blank" rel="noopener" class="nav-link tnt-section-weekly-ads">Weekly Ads</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-10" data-target="#mobile-nav-left_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="http://jobs.heraldextra.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-jobs">Jobs</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a href="/workhere/"  class="nav-link tnt-section-career-opportunities-at-the-daily-herald">Career Opportunities at the Daily Herald</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/community/"  class="nav-link tnt-section-community-table">Community Table</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/eedition"  class="nav-link tnt-section-e-edition">E-Edition</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-13" data-target="#mobile-nav-left_menu-child-13">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/contact/"  class="nav-link tnt-section-contact-us">Contact Us</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-13" class="collapse nav navbar-nav"><li>
                                    <a href="https://www.heraldextra.com/forms/online_services/submit_news/submit_news_imported-1364312062_imported-1364336463/"  target="_blank" rel="noopener" class="nav-link tnt-section-submit-a-news-tip">Submit a News Tip</a>
                                </li><li>
                                    <a href="/contact/"  class="nav-link tnt-section-advertise-with-us">Advertise with us</a>
                                </li><li>
                                    <a href="/workhere/"  class="nav-link tnt-section-work-for-us">Work for Us</a>
                                </li></ul></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link  tnt-section-subscribe"  href="/subscribe" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition" >
                    <span class="nav-label">E-Edition</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsletters"  href="/newsletters" >
                    <span class="nav-label">Newsletters</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-us"  href="/contact/" >
                    <span class="nav-label">Contact Us</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-1371453" class="tncms-block"><div id="weather-1371453" class="weather-current size-medium pull-left">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=84601" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-day-sunny"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">38&deg;</span>
                    
                        <span class="cond">Sunny <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="84601"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-1371453 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Provo, UT
                                
                                 <small>(84601)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Plentiful sunshine. High 54F. Winds WNW at 5 to 10 mph..</p>
                            <h5>Tonight</h5>
                            <p>Mostly clear. Low 29F. Winds NE at 5 to 10 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: October 24, 2019 @ 9:30 am</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=84601"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-1450346" class="tncms-block"><section id="block-1450346" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/30e5a732-5a9a-11e7-bb21-770156bad80b.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/30e5a732-5a9a-11e7-bb21-770156bad80b.png 300w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-1450349" class="tncms-block"><div class="follow-links-1450349 pull-right">
    
    <section id="block-1450349" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/UtahValleyDailyHerald/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://www.twitter.com/heraldextra" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="http://www.pinterest.com/dailyherald" title="Pinterest" target="_blank" rel="noopener" class="btn btn-md btn-link pt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-pinterest"></i>
                    <span class="sr-only">Pinterest</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://www.instagram.com/dailyheraldutah" title="Instagram" target="_blank" rel="noopener" class="btn btn-md btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.heraldextra.com",
  "sameAs" : ["https://www.facebook.com/UtahValleyDailyHerald/","http://www.twitter.com/heraldextra","http://www.pinterest.com/dailyherald","http://www.instagram.com/dailyheraldutah"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1368905" class="tncms-block"><section id="block-1368905" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/d0bde5ba-5a97-11e7-b920-c7b33b4a2499.png?resize=200%2C45 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/d0bde5ba-5a97-11e7-b920-c7b33b4a2499.png 300w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1371451" class="tncms-block"><ul id="site-search-1371451-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1371451" action="/search/" method="GET" >
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-1371451-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1371451-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1371451-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1371451').submit();
        return false;
    });

    $('#site-search-1371451').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1371451 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1371451 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1371451-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1371452" class="tncms-block"><div id="user-controls-1371452" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250" class="user-control-link" rel="nofollow">
                        <span class="fas tnt-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a class="btn btn-block btn-primary" href="https://www.heraldextra.com/users/login/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a href="https://www.heraldextra.com/users/signup/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://www.heraldextra.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://www.heraldextra.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li><a href="https://www.heraldextra.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1371452').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.heraldextra.com/users/logout/" id="user-logout-form-1371452"><input type="hidden" name="referer_url" value="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1682915" class="tncms-block"><div id="notification-button-1682915" class="notification-button stuck" data-control="notification" data-id="1682915" style="display:none;">
            <span class="badge-dot tnt-bg-accent" style="display:none;"></span>
            <i class="fas tnt-bell"></i>
        </div></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link nav-home  tnt-section-utah-news-from-the-daily-herald"  href="/" >
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Utah News from the Daily Herald</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/local/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-local-news"  href="/news/local/" >
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-utah-news"  href="/news/state-and-regional" >
                    <span class="nav-label">Utah News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-national-news"  href="/news/national/" >
                    <span class="nav-label">National News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community-columnists"  href="/news/community/" >
                    <span class="nav-label">Community Columnists</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/news/opinion" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-photo-galleries"  href="/gallery" >
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-special-sections"  href="/special-section" >
                    <span class="nav-label">Special Sections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition"  href="/eedition" >
                    <span class="nav-label">E-Edition</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-cougarblue"  href="/sports/college/byu/" >
                    <span class="nav-label">Cougarblue</span>
                </a></li><li>
                <a class="nav-link  tnt-section-high-school-sports"  href="/sports/high-school" >
                    <span class="nav-label">High School Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-uvu-sports"  href="/sports/college/uvu/" >
                    <span class="nav-label">UVU Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-utah-jazz"  href="/sports/basketball/professional/jazz/" >
                    <span class="nav-label">Utah Jazz</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-entertainment"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/entertainment" >
                    <span class="nav-label">Entertainment</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-dining"  href="/entertainment/dining" >
                    <span class="nav-label">Dining</span>
                </a></li><li>
                <a class="nav-link  tnt-section-music"  href="/entertainment/music" >
                    <span class="nav-label">Music</span>
                </a></li><li>
                <a class="nav-link  tnt-section-arts-and-theater"  href="/entertainment/arts-and-theater/" >
                    <span class="nav-label">Arts and Theater</span>
                </a></li><li>
                <a class="nav-link  tnt-section-events-calendar"  href="/calendar" >
                    <span class="nav-label">Events Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-celebrations"  href="/lifestyles/announcements" >
                    <span class="nav-label">Celebrations</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-faith"  href="/news/local/faith/" >
                    <span class="nav-label">Faith</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/lifestyles/announcements/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/ads/" >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-real-estate"  href="/homes" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link  tnt-section-jobs"  href="https://jobs.heraldextra.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jobs</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business-directory"  href="/places/" >
                    <span class="nav-label">Business Directory</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-jobs"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="http://jobs.heraldextra.com/"  target="_blank" rel="noopener">
                    <span class="nav-label">Jobs</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-career-opportunities-at-the-daily-herald"  href="/workhere/" >
                    <span class="nav-label">Career Opportunities at the Daily Herald</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-deals"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="https://deals.heraldextra.com"  target="_blank" rel="noopener">
                    <span class="nav-label">Deals</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-weekly-ads"  href="http://circulars.heraldextra.com/?locale=en&amp;p=dailyherald&amp;utm_campaign=lee_circ&amp;utm_content=circ&amp;utm_medium=ham_menu&amp;utm_source=heraldextra#!/flyers/jcpenney-distribution?flyer_run_id=449186"  target="_blank" rel="noopener">
                    <span class="nav-label">Weekly Ads</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #206EC6">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&body=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
                
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1368899" class="tncms-block"></div><div id="tncms-block-1429920" class="tncms-block"><div id="PRO_1x1" style="text-align:center">
<script>
googletag.cmd.push(function() { googletag.display('PRO_1x1'); });
</script>
</div></div><div id="tncms-block-1429922" class="tncms-block"><div id="PRO_Bottom_1x1" style="text-align:center">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Bottom_1x1'); });
</script>
</div></div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1429928" class="tncms-block"><div id="Pro_Top_728x90" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('Pro_Top_728x90'); });
</script>
</div></div></div></div>
        </div><div class="modal fullscreen" id="photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926" tabindex="-1" role="dialog" aria-labelledby="photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-body">
                    <button type="button" class="close" data-dismiss="modal">
                        <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                        <span class="sr-only">Close</span>
                    </button>
                    <div id="carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" class="card photo-carousel   has-ad-unit  subscriber-hide">
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            <div id="gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" class="carousel-inner">
                        <div class="item photo-bcbe245c-0a62-50f5-ba9e-542a7c534eff">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Averette&#39;s wait is almost over as UVU basketball season approaches","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fa fa-spinner fa-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800"
                    
                    alt="Brandon Averette UVU mbb media day"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1763"
                    height="1175"
                    data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" data-target=".caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal collapse in"><div class="actions pull-right">
                <a href="http://heraldextra.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2Fcb%2Fbcbe245c-0a62-50f5-ba9e-542a7c534eff%2F5db0d77901cd5.image.jpg%3Fresize%3D540%252C360&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2Fcb%2Fbcbe245c-0a62-50f5-ba9e-542a7c534eff%2F5db0d77901cd5.image.jpg%3Fresize%3D540%252C360&notes=https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77910ade.~townnews~.jpg&pricingsheetid=2770" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div><div class="caption-text"><p>Utah Valley guard Brandon Averette (11) poses with his teammates during basketball media day in Orem on Wednesday, Oct. 23, 2019.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-53416ad6-5013-11de-bf55-001cc4c0325c-asset-bcbe245c-0a62-50f5-ba9e-542a7c534eff" class="tnt-byline asset-byline"  ><a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson">By Darnell Dickson
Daily Herald</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fbrandon-averette-uvu-mbb-media-day%2Fimage_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/brandon-averette-uvu-mbb-media-day/image_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bcbe245c-0a62-50f5-ba9e-542a7c534eff"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Brandon%20Averette%20UVU%20mbb%20media%20day&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fbrandon-averette-uvu-mbb-media-day%2Fimage_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/brandon-averette-uvu-mbb-media-day/image_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bcbe245c-0a62-50f5-ba9e-542a7c534eff"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/bcbe245c-0a62-50f5-ba9e-542a7c534eff" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"bcbe245c-0a62-50f5-ba9e-542a7c534eff"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Brandon%20Averette%20UVU%20mbb%20media%20day&body=https%3A%2F%2Fwww.heraldextra.com%2Fbrandon-averette-uvu-mbb-media-day%2Fimage_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"bcbe245c-0a62-50f5-ba9e-542a7c534eff"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/brandon-averette-uvu-mbb-media-day/image_bcbe245c-0a62-50f5-ba9e-542a7c534eff.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"bcbe245c-0a62-50f5-ba9e-542a7c534eff"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-bcbe245c-0a62-50f5-ba9e-542a7c534eff-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="bcbe245c-0a62-50f5-ba9e-542a7c534eff" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="bcbe245c-0a62-50f5-ba9e-542a7c534eff" class="save-list-bcbe245c-0a62-50f5-ba9e-542a7c534eff-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="bcbe245c-0a62-50f5-ba9e-542a7c534eff" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Averette&#39;s wait is almost over as UVU basketball season approaches","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fa fa-spinner fa-spin"></i></div>
                                            
                                        
                                        
                                        
                                        
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="UVU mbb media day"
                    class="img-responsive owl-lazy"
                    width="1763"
                    height="1175"
                    data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7797ec21.image.jpg?resize=1200%2C800" />
                                        
                                        
                                </div>
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" data-target=".caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal collapse in"><div class="actions pull-right">
                <a href="http://heraldextra.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2F7%2Ffb%2F7fbdf1d5-a91c-5874-a0b6-f222a1dd9539%2F5db0d7797ec21.image.jpg%3Fresize%3D540%252C360&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2F7%2Ffb%2F7fbdf1d5-a91c-5874-a0b6-f222a1dd9539%2F5db0d7797ec21.image.jpg%3Fresize%3D540%252C360&notes=https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7798ddc1.~townnews~.jpg&pricingsheetid=2770" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div><div class="caption-text"><p>The Utah Valley men's basketball team prepares for photos during media day in Orem on Wednesday, Oct. 23, 2019.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-53416ad6-5013-11de-bf55-001cc4c0325c-asset-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" class="tnt-byline asset-byline"  ><a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson">By Darnell Dickson
Daily Herald</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fuvu-mbb-media-day%2Fimage_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/uvu-mbb-media-day/image_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7fbdf1d5-a91c-5874-a0b6-f222a1dd9539"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=UVU%20mbb%20media%20day&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fuvu-mbb-media-day%2Fimage_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/uvu-mbb-media-day/image_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7fbdf1d5-a91c-5874-a0b6-f222a1dd9539"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"7fbdf1d5-a91c-5874-a0b6-f222a1dd9539"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20UVU%20mbb%20media%20day&body=https%3A%2F%2Fwww.heraldextra.com%2Fuvu-mbb-media-day%2Fimage_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"7fbdf1d5-a91c-5874-a0b6-f222a1dd9539"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/uvu-mbb-media-day/image_7fbdf1d5-a91c-5874-a0b6-f222a1dd9539.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"7fbdf1d5-a91c-5874-a0b6-f222a1dd9539"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" class="save-list-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </div>
    </div>
        <script>
            jQuery(document).ready(function($){
                $('#photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926').on('show.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').addClass('overlay-leaderboard');
                });
                $('#photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926').on('hide.bs.modal', function(e){
                    $('#fixed-leaderboard-top-container').removeClass('overlay-leaderboard');
                });
            });
        </script><article itemscope itemtype="https://schema.org/Article" id="asset-8f580909-f0b1-508c-9759-b3b7f4474926" class="asset article-default"  data-url="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=945%2C630">
            <meta itemprop="width" content="945">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="heraldextra.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" />
    <style>
                .asset-paging .direction {
                    color: #206ec6;
                }
            </style><div class="asset-paging-container hidden-print">
            <div id="asset-paging-8f580909-f0b1-508c-9759-b3b7f4474926" class="asset-paging">
                <div id="paging-prev-8f580909-f0b1-508c-9759-b3b7f4474926" class="paging-link prev offset"></div>
                <div id="paging-next-8f580909-f0b1-508c-9759-b3b7f4474926" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-editors-pick">editor's pick</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Averette's wait is almost over as UVU basketball season approaches
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-53416ad6-5013-11de-bf55-001cc4c0325c-asset-8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson">By Darnell Dickson
Daily Herald
</a></span>
                
                    <div id="author-popup-53416ad6-5013-11de-bf55-001cc4c0325c-asset-8f580909-f0b1-508c-9759-b3b7f4474926-content" class="hide">
                        <article class="clearfix card author popup-content card-author-53416ad6-5013-11de-bf55-001cc4c0325c">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Darnell Dickson"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/avatars/5/34/16a/53416ad6-5013-11de-bf55-001cc4c0325c.662d97f035a8513cd59eae9f53da0590.png?_dc=1456254903"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson" rel="author" class="tnt-user-profile-link tnt-user-name">Darnell Dickson</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="https://www.facebook.com/Darnell-Dickson-768466646546122/" title="Facebook" target="_blank" rel="noopener">
                   <span class="sr-only">Author facebook</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="http://www.twitter.com/darnellwrites" title="Twitter" target="_blank" rel="noopener">
                    <span class="sr-only">Author twitter</span>
                    <span class="tnt-stack">
                       
                       <i class="fab tnt-twitter tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="mailto:ddickson@heraldextra.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-53416ad6-5013-11de-bf55-001cc4c0325c-asset-8f580909-f0b1-508c-9759-b3b7f4474926').popover({
                            content: $('#author-popup-53416ad6-5013-11de-bf55-001cc4c0325c-asset-8f580909-f0b1-508c-9759-b3b7f4474926-content').html(),
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li>
        <time datetime="2019-10-24T05:45:00-06:00" class="tnt-date asset-date text-muted">3 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html#comments" class="cm"><span class="fas tnt-comments"></span> <span twt-comment-count="https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" twt-article-id="8f580909-f0b1-508c-9759-b3b7f4474926">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2019-10-24T05:45:00-06:00">
    <meta itemprop="datePublished" content="2019-10-24T05:45:00-06:00">
    <meta itemprop="dateModified" content="2019-10-24T05:45:00-06:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >    
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&body=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div id="asset-photo-carousel"><div id="carousel-8f580909-f0b1-508c-9759-b3b7f4474926" class="card photo-carousel    subscriber-hide">
            <div class="photo-carousel-control-container">
                    <span class="photo-count">
                        <span class="current-count">1</span> of 2
                    </span>
                    <a class="photo-carousel-control left noselect"><span class="control-left fas tnt-chevron-left"></span></a>
                    <a class="photo-carousel-control right noselect"><span class="control-left fas tnt-chevron-right"></span></a>
            </div>
            <div id="gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926" class="carousel-inner">
                        <div class="item photo-bcbe245c-0a62-50f5-ba9e-542a7c534eff">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Averette&#39;s wait is almost over as UVU basketball season approaches","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926","app":"editorial","metric":""}'  data-count="1"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fa fa-spinner fa-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#1" data-photo-target=".photo-bcbe245c-0a62-50f5-ba9e-542a7c534eff" data-instance="#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" data-target="#photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fa fa-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1763">
            <meta itemprop="height" content="1175">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800">
        
                <img
                    src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800"
                    
                    alt="Brandon Averette UVU mbb media day"
                    class="img-responsive owl-first-image owl-lazy"
                    width="1763"
                    height="1175"
                    data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?resize=1200%2C800" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926 collapse in"><div class="actions pull-right">
                <a href="http://heraldextra.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2Fcb%2Fbcbe245c-0a62-50f5-ba9e-542a7c534eff%2F5db0d77901cd5.image.jpg%3Fresize%3D540%252C360&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2Fb%2Fcb%2Fbcbe245c-0a62-50f5-ba9e-542a7c534eff%2F5db0d77901cd5.image.jpg%3Fresize%3D540%252C360&notes=https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77910ade.~townnews~.jpg&pricingsheetid=2770" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div><div class="caption-text"><p>Utah Valley guard Brandon Averette (11) poses with his teammates during basketball media day in Orem on Wednesday, Oct. 23, 2019.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-53416ad6-5013-11de-bf55-001cc4c0325c-asset-bcbe245c-0a62-50f5-ba9e-542a7c534eff" class="tnt-byline asset-byline"  ><a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson">By Darnell Dickson
Daily Herald</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
                        <div class="item photo-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539 hidden-print">
                            <div class="item-container">
        
                                <div data-track-object='{"title":"Averette&#39;s wait is almost over as UVU basketball season approaches","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926","app":"editorial","metric":""}'  data-count="2"  class="photo-container layout-horizontal">
                                            <div class="loading-slide text-center"><i class="fa fa-spinner fa-spin"></i></div>
                                            
                                        
                                        
                                            <a href="#2" data-photo-target=".photo-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" data-instance="#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal" data-target="#photo-carousel-8f580909-f0b1-508c-9759-b3b7f4474926" class="hover-expand">
                                                <span class="expand">
                                                    <span class="fa fa-expand"></span>
                                                </span>
                                        
                                        
                                        
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1763">
            <meta itemprop="height" content="1175">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7797ec21.image.jpg?resize=1200%2C800">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7797ec21.image.jpg?resize=1200%2C800">
        
                <img
                    src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                    alt="UVU mbb media day"
                    class="img-responsive owl-lazy"
                    width="1763"
                    height="1175"
                    data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7797ec21.image.jpg?resize=1200%2C800" />
            </div>
                                        
                                        </a><div class="clearfix"></div>
                                </div>
        <div class="caption-container">
            <div class="caption-inner-8f580909-f0b1-508c-9759-b3b7f4474926 collapse in"><div class="actions pull-right">
                <a href="http://heraldextra.mycapture.com/mycapture/remoteimage.asp?backtext=Return%20to%20photo&backurl=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html&thumbpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2F7%2Ffb%2F7fbdf1d5-a91c-5874-a0b6-f222a1dd9539%2F5db0d7797ec21.image.jpg%3Fresize%3D540%252C360&previewpath=https%3A%2F%2Fbloximages.chicago2.vip.townnews.com%2Fheraldextra.com%2Fcontent%2Ftncms%2Fassets%2Fv3%2Feditorial%2F7%2Ffb%2F7fbdf1d5-a91c-5874-a0b6-f222a1dd9539%2F5db0d7797ec21.image.jpg%3Fresize%3D540%252C360&notes=https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/7/fb/7fbdf1d5-a91c-5874-a0b6-f222a1dd9539/5db0d7798ddc1.~townnews~.jpg&pricingsheetid=2770" class="tnt-photo-purchase btn btn-default btn-xs" target="_blank" rel="noopener">Buy Now</a>
            </div><div class="caption-text"><p>The Utah Valley men's basketball team prepares for photos during media day in Orem on Wednesday, Oct. 23, 2019.</p></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span id="author-53416ad6-5013-11de-bf55-001cc4c0325c-asset-7fbdf1d5-a91c-5874-a0b6-f222a1dd9539" class="tnt-byline asset-byline"  ><a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson">By Darnell Dickson
Daily Herald</a></span>
                </li>
                                
                            
                            
                            
                        </ul>
                    </div>
            </div>
        </div>
    <div class="clearfix"></div>
                            </div>
                        </div>
            </div>
        </div></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="8f580909-f0b1-508c-9759-b3b7f4474926">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&body=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8f580909-f0b1-508c-9759-b3b7f4474926" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&body=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8f580909-f0b1-508c-9759-b3b7f4474926" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>It’s been 581 days since Brandon Averette played in an actual college basketball game.</p><p>The speedy 5-foot-11 point guard’s last appearance was in the orange and black of Oklahoma State, playing 21 minutes in a 92-84 loss to Western Kentucky in the NIT on March 21, 2018.</p><p>That’s 581 days for Averette to work on his game. That’s 581 days to focus on becoming a better teammate. That’s 581 days of waiting to wear the green and white of Utah Valley.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"><div id="tncms-block-1715602" class="tncms-block"><div class="visible-xs" id="PRO_Middle1_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle1_300x250'); });
</script>
</div></div></div><p>He has another 13 days to wait until the official season opener at the UCCU Center against Westminster.</p><p>He says he’s ready.</p><p>“I believe the hype in myself,” Averette said. “This feels like it’s been forever just waiting for this. I’ve just been working. I’m ready to go out there and show what I’ve been working on.”</p><p>Averette played in 36 games for Oklahoma State during the 2017-18 season, leading the Cowboys in assists (2.9 per game) while averaging six points per contest. He transferred to play for Mark Pope and the Wolverines and sat out the 2018-19 season. Then Pope left for the BYU job and Averette was introduced to former NBA assistant coach Mark Madsen, the new man at UVU.</p><p>“The thing about Coach Madsen is how genuine he is,” Averette said. “In college basketball it’s hard to find someone as genuine as Madsen. He’s a real person and he’s always trying to help. He really cares about us as people more than basketball players. That’s really what stands out to me.”</p><p>Averette said he focused on becoming a better shooter during his redshirt season with confidence and repetition the focus every day.</p><p>“What I saw here was an opportunity to do something really special,” Averette said. “We haven’t been to the NCAA Tournament in school history so just to have the opportunity to take the team there for the first time, it’s something I really want to keep going and push toward.”</p><p>Madsen said Averette will be an impact player for the Wolverines right away.</p><p>“I would describe him as a tremendous competitor,” Madsen said. “He’s a great shooter. Brandon is someone who is an elite defender and can guard multiple positions. He can impact the game in so many different ways.”</p><p>Averette isn’t alone in having a long wait to get back on the basketball floor. He was joined by two other transfers — former Boise State guard Casden Jardine and former Fordham guard Cavit Ege Havsa — who both also elected to stay and play for Madsen after Pope left.</p><p>“He (Madsen) is the most interesting coach I’ve ever had,” Jardine said. “His coaching style is different than I’ve ever been a part of. His knowledge of the game is incredible. He’s always calm and always collected. I’m super excited to play for him and to learn from him. It’s incredible to know that you’re your coach is a two-time NBA champion and has coached in the League. To be a part of that is pretty special.”</p><p>Madsen said all three of the transfers are ready for their debuts in a Wolverine uniform.</p><p>“They spent all last year battling with teammates and they’ve been battling teammates this summer,” he said. “They are ready to be turned loose on other teams and I’m excited for that moment.”</p><p>Madsen said the focus over the past five months since he took the job was to install the offensive and defensive systems.</p><p>“The players are understanding the goals and the emphasis points,” he said. “Now it’s about perfecting it. Now it’s taking it from a good level to an even higher level so we can get the type of results we want. Collectively, the guys have really bought in. Collectively, the guys have all done a great job. Every single player, one to 15, has been phenomenal, working hard, bringing the energy every day and the effort every day.”</p><p>Utah Valley, which was picked to finish sixth by both the media and coaches in the preseason WAC voting — will play a closed scrimmage on Saturday against the University of Montana, followed by an exhibition game against College of Idaho on Nov. 1. The Wolverines officially open the season at home against Westminster on Nov. 5.</p><h2>UVU women’s basketball</h2><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1715603" class="tncms-block"><div class="visible-xs" id="PRO_Middle2_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle2_300x250'); });
</script>
</div></div></div><p>There is also a new head coach for the women’s team: Former BYU assistant Dan Nielson. He brought three former Cougar players — Ashley Garfield, Morgan Bailey and Keilani Unga — to join his coaching staff as well.</p><p>The Wolverines have been mainly a zone defensive team but Nielson and his staff have been putting the team to the test by playing more man to man.</p><p>“We play man now,” said Jordan Holland, the team’s top returning scorer and a senior. “So that will be a complete difference. Our man defense is coming together really well and it will be hard to play against.</p><p>It’ll be more up tempo, definitely.”</p><p>Neilson said defense has been the focus during the spring and summer since taking over the program.</p><p>“They’ve gone the last couple of years playing a lot of zone defense, so we spent a lot of time playing man to man and teaching basic principles,” Nielson said. “The great thing is the girls have really bought in. We’ve had good level of intensity and buy in from the girls and we’re just excited to get going. We know this year there will be ups and downs and we’re hoping there will be more ups than downs. I think we have a chance to be better probably than people expect.”</p><p>The three seniors — Holland, Alexis Cortez and Keana Delos Santos — have taken a leadership role on what will be one of the most experienced teams in the Western Athletic Conference.</p><p>“The great thing is I feel like our chemistry has improved since we got here,” Nielson said. “The girls have said they are having fun and they are enjoying playing basketball together. It’s been the seniors that are leading the charge both with their talent and their example. They are really wanting to go out with a bang for their senior year and do something more than they have the past couple of years.”</p><p>Like the men’s team, the Wolverines have never been to the NCAA Tournament since becoming a Division I-level program for the 2003-04 season.</p><p>“Every coach is the eternal optimist — at least, you should be, otherwise this can be a tough business,” Nielson said. “We’re going to take it one game at a time but once you get to the (WAC) tournament in March, the goal is to win it and go to the NCAA Tournament, because that improves everything. That improves recruiting and the goal is to go as far as we can and I think that’s a realistic thing. The beauty of the WAC is that New Mexico State has dominated but they graduated a lot of players and I think it’s really wide open. Anybody can win it this year.”</p><p>The Wolverines — picked to finish fifth by the media and sixth by the coaches in the WAC — have an exhibition game on Saturday against Western Colorado and open the season on the road at UC Santa Barbara on Nov. 5.</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"><div id="tncms-block-1715604" class="tncms-block"><div class="visible-xs" id="PRO_Middle3_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle3_300x250'); });
</script>
</div></div></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
                                <div class="asset-tagline text-muted"><p>Follow Darnell Dickson on Twitter @darnellwrites or e-mail him at <a href="mailto:ddickson@heraldextra.com">ddickson@heraldextra.com</a>.<!--p:BC TAG Body Copy Tagline--></p></div>
                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >    
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&via=heraldextra&url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.heraldextra.com/tncms/asset/editorial/8f580909-f0b1-508c-9759-b3b7f4474926" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BHerald%20Communications%5D%20Averette%27s%20wait%20is%20almost%20over%20as%20UVU%20basketball%20season%20approaches&body=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"8f580909-f0b1-508c-9759-b3b7f4474926"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="8f580909-f0b1-508c-9759-b3b7f4474926" class="save-list-8f580909-f0b1-508c-9759-b3b7f4474926-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="8f580909-f0b1-508c-9759-b3b7f4474926" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22brandon%20averette%22#tncms-source=keyword" class="tag-brandon-averette label label-default" >Brandon Averette</a>
            </li> <li>
                <a href="/search/?k=%22mark%20madsen%22#tncms-source=keyword" class="tag-mark-madsen label label-default" >Mark Madsen</a>
            </li> <li>
                <a href="/search/?k=%22coach%22#tncms-source=keyword" class="tag-coach label label-default" >Coach</a>
            </li> <li>
                <a href="/search/?k=%22mark%20pope%22#tncms-source=keyword" class="tag-mark-pope label label-default" >Mark Pope</a>
            </li> <li>
                <a href="/search/?k=%22sport%22#tncms-source=keyword" class="tag-sport label label-default" >Sport</a>
            </li> <li>
                <a href="/search/?k=%22basketball%22#tncms-source=keyword" class="tag-basketball label label-default" >Basketball</a>
            </li> <li>
                <a href="/search/?k=%22dan%20nielson%22#tncms-source=keyword" class="tag-dan-nielson label label-default" >Dan Nielson</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-53416ad6-5013-11de-bf55-001cc4c0325c">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        
    
        <img
            alt="Darnell Dickson"
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
            data-src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/avatars/5/34/16a/53416ad6-5013-11de-bf55-001cc4c0325c.662d97f035a8513cd59eae9f53da0590.png?_dc=1456254903"
            class="img-responsive lazyload tnt-user-avatar" />
    

                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.heraldextra.com/users/profile/Darnell%20Dickson" rel="author" class="tnt-user-profile-link tnt-user-name">Darnell Dickson</a>
                                </h4>
                                    <p class="card-about">Darnell Dickson, who has been covering sports in Utah since 1989 (with a detour to Nebraska for three years somewhere in there), is currently the BYU football columnist and BYU men’s basketball beat writer.</p>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="https://www.facebook.com/Darnell-Dickson-768466646546122/" title="Facebook" target="_blank" rel="noopener">
                   <span class="sr-only">Author facebook</span>
                   <span class="tnt-stack">
                       
                       <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="http://www.twitter.com/darnellwrites" title="Twitter" target="_blank" rel="noopener">
                    <span class="sr-only">Author twitter</span>
                    <span class="tnt-stack">
                       
                       <i class="fab tnt-twitter tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
            <li>
                <a href="mailto:ddickson@heraldextra.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-53416ad6-5013-11de-bf55-001cc4c0325c" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=53416ad6-5013-11de-bf55-001cc4c0325c&amp;s=start_time&amp;sd=desc" data-subject="Darnell Dickson" data-description="Whenever Darnell Dickson posts new content, you'll get an email delivered to your inbox with a link." data-name="Darnell Dickson notification" data-author-id="53416ad6-5013-11de-bf55-001cc4c0325c" data-user-url="https://www.heraldextra.com/users/">
        <i class="fas tnt-star"></i> Follow Darnell Dickson
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" >
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.heraldextra.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.heraldextra.com/users/login/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.heraldextra.com/users/signup/?referer_url=https%3A%2F%2Fwww.heraldextra.com%2Fsports%2Fcollege%2Fuvu%2Fbasketball-men%2Faverette-s-wait-is-almost-over-as-uvu-basketball-season%2Farticle_8f580909-f0b1-508c-9759-b3b7f4474926.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    

                    <!-- jsandy #667059
    <script id="twt-embed" type="text/javascript"> window.twtConfig = {
    publisherId: '000001587955d1af_f298641',
    siteId: '000001587956b995_2a5f1c1',
    authorId: 'Darnell Dickson',
    pageTitle: document.title.split('|').shift().trim(),
    permalink: 'https://www.heraldextra.com/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html',
    publishedAt: null /* Can be null or milliseconds since 1970/01/01 */
    }; (function () { var twt = document.createElement('script'); twt.type = 'text/javascript'; twt.async = true; twt.src = '//app.worldtable.co/embed.js'; (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(twt); }()); </script>
    -->

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
                <div class="comments-container">
                    
                    <div id="comments">
                        <div id="twt-comments"></div>
                        
                            <div class="alert alert-info text-center">
                               See what people are talking about at <a class="btn btn-primary btn-sm" href="https://www.heraldextra.com/community/" style="margin-left:8px;" >The Community Table!</a>
                            </div>
                        
                    </div>
                </div>
            
        </div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1429924" class="tncms-block"><div id="PRO_Middle1_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle1_300x250'); });
</script>
</div></div><div id="tncms-block-1371204" class="tncms-block"><section id="block-1371204" class="block emphasis-h3   " ><div class="clearfix"></div><div class="heading card">
    
    
    <div class="clearfix">
    
    <div class="block-title title-1371204 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="/sports/college/uvu/basketball-men">
                
                Top Comments
                
                    </a>
                
            </h3>
        </div>
    </div></div>
    
</div></section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1429925" class="tncms-block"><div id="PRO_Middle2_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle2_300x250'); });
</script>
</div></div><div id="tncms-block-1378961" class="tncms-block block-light"><section id="block-1378961" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1378961 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/uvu-men-s-hoops-picked-sixth-in-wac-preseason-polls/article_c8c37bf5-2a3b-5e6c-8692-bb44eaed9c69.html" class="tnt-asset-link">
        

        
            UVU men's hoops picked sixth in WAC preseason polls</a></h4>
                    
                </li></ul>
    </div>
    
</section></div><div id="tncms-block-1378960" class="tncms-block block-light"><section id="block-1378960" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1378960 ">
        <div class="block-title-inner">
            <h3>
                
                Latest in section
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-sm card-compact">
        
                
                <article id="card-summary-1378960-8f580909-f0b1-508c-9759-b3b7f4474926" class="clearfix card summary has-image image-left inherit  tnt-section-sports tnt-sub-section-college tnt-sub-section-uvu tnt-sub-section-basketball-men">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-8f580909-f0b1-508c-9759-b3b7f4474926 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="Averette's wait is almost over as UVU basketball season approaches"
                        class="img-responsive lazyload full"
                        width="1763"
                        height="992"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/b/cb/bcbe245c-0a62-50f5-ba9e-542a7c534eff/5db0d77901cd5.image.jpg?crop=1763%2C992%2C0%2C91&resize=1700%2C956&order=crop%2Cresize 1700w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/averette-s-wait-is-almost-over-as-uvu-basketball-season/article_8f580909-f0b1-508c-9759-b3b7f4474926.html" class="tnt-asset-link">
        

        
            Averette's wait is almost over as UVU basketball season approaches</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1378960-c8c37bf5-2a3b-5e6c-8692-bb44eaed9c69" class="clearfix card summary has-image image-left inherit  tnt-section-sports tnt-sub-section-college tnt-sub-section-uvu tnt-sub-section-basketball-men">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-c8c37bf5-2a3b-5e6c-8692-bb44eaed9c69 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="/sports/college/uvu/basketball-men/uvu-men-s-hoops-picked-sixth-in-wac-preseason-polls/article_c8c37bf5-2a3b-5e6c-8692-bb44eaed9c69.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="UVU men's hoops picked sixth in WAC preseason polls"
                        class="img-responsive lazyload full"
                        width="1040"
                        height="585"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/d/4c/d4c7462f-cf19-5ccd-9bce-d53b1c8da7bd/5d9e0bbf6a9f2.image.jpg?crop=1040%2C585%2C0%2C24&resize=1040%2C585&order=crop%2Cresize 1200w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/uvu-men-s-hoops-picked-sixth-in-wac-preseason-polls/article_c8c37bf5-2a3b-5e6c-8692-bb44eaed9c69.html" class="tnt-asset-link">
        

        
            UVU men's hoops picked sixth in WAC preseason polls</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1378960-f1ee7fef-7fb1-5aa1-b3e6-9c5ed307bb74" class="clearfix card summary has-image image-left inherit  tnt-section-sports tnt-sub-section-college tnt-sub-section-uvu tnt-sub-section-basketball-men">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-f1ee7fef-7fb1-5aa1-b3e6-9c5ed307bb74 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="/sports/college/uvu/basketball-men/uvu-men-s-basketball-adds-assistant-coach/article_f1ee7fef-7fb1-5aa1-b3e6-9c5ed307bb74.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="UVU men's basketball adds assistant coach"
                        class="img-responsive lazyload full"
                        width="1175"
                        height="661"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/1/e2/1e2d1ed6-c290-5038-acf3-3fa1c4fc27d5/5d6052a6cac44.image.jpg?crop=1175%2C661%2C0%2C551&resize=1175%2C661&order=crop%2Cresize 1200w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/uvu-men-s-basketball-adds-assistant-coach/article_f1ee7fef-7fb1-5aa1-b3e6-9c5ed307bb74.html" class="tnt-asset-link">
        

        
            UVU men's basketball adds assistant coach</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1378960-d3d55ea1-a7b6-5d90-95f2-d2dd5c149e8e" class="clearfix card summary has-image image-left inherit  tnt-section-sports tnt-sub-section-college tnt-sub-section-uvu tnt-sub-section-basketball-men">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-d3d55ea1-a7b6-5d90-95f2-d2dd5c149e8e media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="/sports/college/uvu/basketball-men/uvu-men-s-basketball-releases---schedule/article_d3d55ea1-a7b6-5d90-95f2-d2dd5c149e8e.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="UVU men's basketball releases 2019-20 schedule"
                        class="img-responsive lazyload full"
                        width="1548"
                        height="871"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/6/54/65448a3e-5a4e-5542-9099-f17076d5ff3a/5d0d3d9a103b9.image.jpg?crop=1548%2C871%2C0%2C234&resize=1548%2C871&order=crop%2Cresize 1700w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/uvu-men-s-basketball-releases---schedule/article_d3d55ea1-a7b6-5d90-95f2-d2dd5c149e8e.html" class="tnt-asset-link">
        

        
            UVU men's basketball releases 2019-20 schedule</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-1378960-cbcea484-8e5e-58c4-9628-6572f758f443" class="clearfix card summary has-image image-left inherit  tnt-section-sports tnt-sub-section-college tnt-sub-section-uvu tnt-sub-section-basketball-men">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-cbcea484-8e5e-58c4-9628-6572f758f443 media-preview article-asset" data-aspect="16:9"><figure class="photo layout-horizontal">
            <div class="image" 
                >
                
                    <a href="/sports/college/uvu/basketball-men/woodbury-signs-with-uvu-men-s-basketball/article_cbcea484-8e5e-58c4-9628-6572f758f443.html" class="tnt-asset-link">
                
                
                
                
        
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="Woodbury signs with UVU men's basketball"
                        class="img-responsive lazyload full"
                        width="1763"
                        height="992"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=300%2C169&order=crop%2Cresize 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=400%2C225&order=crop%2Cresize 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=540%2C304&order=crop%2Cresize 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=750%2C422&order=crop%2Cresize 750w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=1200%2C675&order=crop%2Cresize 1200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/assets/v3/editorial/5/07/5072ea56-7f44-5a2a-a2bc-74baffc979c9/5d15101723849.image.jpg?crop=1763%2C992%2C0%2C91&resize=1700%2C956&order=crop%2Cresize 1700w" />
                </a>
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body"><div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/college/uvu/basketball-men/woodbury-signs-with-uvu-men-s-basketball/article_cbcea484-8e5e-58c4-9628-6572f758f443.html" class="tnt-asset-link">
        

        
            Woodbury signs with UVU men's basketball</a></h4></div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-1429926" class="tncms-block"><div id="PRO_Middle3_300x250" style="text-align:center;margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Middle3_300x250'); });
</script>
</div></div><div id="tncms-block-1379618" class="tncms-block"></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "><div id="tncms-block-1429923" class="tncms-block"><div id="PRO_Bottom_728x90" style="text-align:center; margin-bottom:10px;">
<script>
googletag.cmd.push(function() { googletag.display('PRO_Bottom_728x90'); });
</script>
</div></div></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1378799" class="tncms-block"><section id="block-1378799" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" ><img 
            
            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
            data-srcset="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/8474f28c-1967-11e7-a0b7-7fde6a27600b.png?resize=200%2C42 200w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/8474f28c-1967-11e7-a0b7-7fde6a27600b.png?resize=300%2C62 300w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/8474f28c-1967-11e7-a0b7-7fde6a27600b.png?resize=400%2C83 400w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/8474f28c-1967-11e7-a0b7-7fde6a27600b.png?resize=540%2C112 540w, https://bloximages.chicago2.vip.townnews.com/heraldextra.com/content/tncms/custom/image/8474f28c-1967-11e7-a0b7-7fde6a27600b.png 750w" 
            data-sizes="auto" 
            class=" img-responsive lazyload tnt-prop-img"
            alt=""></a></div></section></div><div id="tncms-block-1368911" class="tncms-block padding-bottom"><div class="follow-links-1368911 default">
    
    <section id="block-1368911" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/UtahValleyDailyHerald/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/heraldextra" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/dailyherald" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://www.pinterest.com/dailyherald" title="Pinterest" target="_blank" rel="noopener" class="btn btn-xs btn-link pt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-pinterest"></i>
                    <span class="sr-only">Pinterest</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://www.instagram.com/dailyheraldutah/" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.heraldextra.com",
  "sameAs" : ["https://www.facebook.com/UtahValleyDailyHerald/","https://twitter.com/heraldextra","https://www.youtube.com/dailyherald","http://www.pinterest.com/dailyherald","https://www.instagram.com/dailyheraldutah/"]
}
</script>
<div class="clearfix"></div></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-customer-service"  href="https://webport05.voiceport.net/provodh/IFrameGUI/index.html?tenant=provodh"  target="_blank" rel="noopener">
                    <span class="nav-label">Customer Service</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe-to-the-daily-herald"  href="/subscribenow/" >
                    <span class="nav-label">Subscribe to the Daily Herald</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-the-daily-herald"  href="/contact/" >
                    <span class="nav-label">Contact the Daily Herald</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-service"  href="/terms/" >
                    <span class="nav-label">Terms of Service</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1368901" class="tncms-block"><section id="block-1368901" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1368901 ">
        <div class="block-title-inner">
            <h3>
                
                Sites &amp; Partners
                
            </h3>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-the-pyramid"  href="/sanpete-county/" >
                    <span class="nav-label">The Pyramid</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cougarblue"  href="/sports/college/byu/" >
                    <span class="nav-label">Cougarblue</span>
                </a></li><li>
                <a class="nav-link  tnt-section-prep-rally"  href="/sports/high-school/" >
                    <span class="nav-label">Prep Rally</span>
                </a></li><li>
                <a class="nav-link  tnt-section-the-ticket"  href="/entertainment" >
                    <span class="nav-label">The Ticket</span>
                </a></li><li>
                <a class="nav-link  tnt-section-utah-adventure"  href="/utahadventure/" >
                    <span class="nav-label">Utah Adventure</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1368852" class="tncms-block"><section id="block-1368852" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1368852 ">
        <div class="block-title-inner">
            <h3>
                
                Tools &amp; Services
                
            </h3>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-mobile-apps"  href="/apps/" >
                    <span class="nav-label">Mobile Apps</span>
                </a></li><li>
                <a class="nav-link  tnt-section-activate-your-digital-access"  href="https://www.heraldextra.com/users/login/?source=activate&amp;referer_url="  target="_blank" rel="noopener">
                    <span class="nav-label">Activate Your Digital Access</span>
                </a></li><li>
                <a class="nav-link  tnt-section-e-edition-newspaper"  href="/e-edition/" >
                    <span class="nav-label">E-Edition Newspaper</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-news-tip"  href="https://www.heraldextra.com/forms/online_services/submit_news/submit_news_imported-1364312062_imported-1364336463/"  target="_blank" rel="noopener">
                    <span class="nav-label">Submit a News Tip</span>
                </a></li><li>
                <a class="nav-link  tnt-section-advertise"  href="/company/advertising/" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscribe-to-email-updates"  href="/newsletters/" >
                    <span class="nav-label">Subscribe to Email Updates</span>
                </a></li><li>
                <a class="nav-link  tnt-section-business-marketplace"  href="/places/" >
                    <span class="nav-label">Business Marketplace</span>
                </a></li><li>
                <a class="nav-link  tnt-section-apply-to-work-at-the-daily-herald"  href="/workhere/" >
                    <span class="nav-label">Apply to work at the Daily Herald</span>
                </a></li></ul></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1368856" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1368856"><div class="col-md-7"><small>&copy; Copyright 2019 <a href="/">Herald Communications</a>, 86 N. University Ave. #300 Provo, UT</small><small>&nbsp;| <a href="/terms/">Terms of Use</a></small><small>&nbsp;| <a href="/privacy/">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    <div id="notification-panel" class="notify-panel notify-panel-from-right">
            <template>
                <div class="notification-item">
                    <a href="{{url}}" target="_blank"></a>
                    <div class="notification-item-card">
                        <div class="notification-item-image"><img src="{{image}}"></div>
                        <div class="notification-item-content">
                            <div class="notification-item-header">{{title}}</div>
                            <div class="notification-item-summary">{{summary}}</div>
                        </div>
                    </div>
                    <div class="notification-item-dismiss">
                        <i class="fas tnt-times tnt-fw"></i>
                    </div>
                </div>
            </template>
            <div class="notify-panel-container">
                <div class="notify-panel-header">
                    <div class="notify-panel-close"><i class="fas tnt-times tnt-fw"></i></div>
                    <div class="notify-panel-nav" role="tablist">
                        <ul>
                            <li class="active" role="presentation"><a href="#notify-panel-content" role="tab" data-toggle="tab">Notifications</a></li>
                            <li role="presentation"><a href="#notify-panel-settings" role="tab" data-toggle="tab">Settings</a></li>
                        </ul>
                    </div>
                </div>
                <div class="tab-content">
                    <div id="notify-panel-content" class="tab-pane active" role="tabpanel">
                        <div class="notify-panel-content-items"></div>
                        <div class="notify-panel-content-no-items" style="display:none;">You don't have any notifications.</div>
                    </div>
                    <div id="notify-panel-settings" class="tab-pane" role="tabpanel">
                        <div class="notify-panel-settings-promo">
                            <p>Get up-to-the-minute news sent straight to your device.</p>
                        </div>
                        
                        <h5>Topics</h5>
                        
                            <div class="topic-container" data-name="BYU_Sports">
                                <h4>BYU Sports</h4>
                                <label class="switch-label">
                                    <input id="topic-BYU_Sports" class="switch-input" title="topic-BYU_Sports" name="topic-BYU_Sports" data-topic="BYU_Sports" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="Breaking">
                                <h4>Breaking News</h4>
                                <label class="switch-label">
                                    <input id="topic-Breaking" class="switch-input" title="topic-Breaking" name="topic-Breaking" data-topic="Breaking" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                            <div class="topic-container" data-name="Entertainment">
                                <h4>Local Entertainment</h4>
                                <label class="switch-label">
                                    <input id="topic-Entertainment" class="switch-input" title="topic-Entertainment" name="topic-Entertainment" data-topic="Entertainment" type="checkbox">
                                    <div class="switch-track"></div>
                                    <div class="switch-thumb"></div>
                                </label>
                            </div>
                        
                        
                        <div class="notify-panel-settings-error alert alert-danger" style="display:none; opacity:0;"></div>
                        <div class="notify-panel-settings-success alert alert-success" style="display:none; opacity:0;"></div>
                    </div>
                </div>
            </div>
        </div>
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'gaTriggerEvent',
                        'gaEventCategory': obj.category,
                        'gaEventAction': obj.action,
                        'gaEventLabel': obj.label,
                        'gaEventValue': obj.value
                    });
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'socialEvent',
                        'socialNetwork': obj.network,
                        'socialAction': obj.socialAction,
                        'socialTarget': obj.url
                    });
                    
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                }
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'VirtualPageview',
                        'virtualPageURL': sURL,
                        'virtualPageTitle': obj.title
                    });
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.b419cb3c218ef0da9fa281dd92729a83.js"></script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1368913 = $('#user-controls-1368913 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1368913.append('<img src="' + __tnt.user.avatar + '" class="user-icon" alt="user-icon">');
        } else{
            avatar_1368913.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1371452 = $('#user-controls-1371452 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1371452.append('<img src="' + __tnt.user.avatar + '" class="user-icon" alt="user-icon">');
        } else{
            avatar_1371452.append('<i class="fas tnt-user tnt-fw user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/heraldextra.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/owl.carousel.min.a23229b8d8ee5f1919a5a9663946b1f7.js"></script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                var gallery_ad_8f580909_f0b1_508c_9759_b3b7f4474926_photo_modal = false;
                var gallery_changed_8f580909_f0b1_508c_9759_b3b7f4474926_photo_modal = false;
                $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .owl-stage-outer").height( $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        

                        
                            var currItem = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926_photo_modal = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal').data('owlCarousel');
                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926_photo_modal.prev();
                });
                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926-photo-modal .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926_photo_modal.next();
                });
            }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                // open photo modal
                jQuery(document).ready(function($){
                    $('[data-photo-target]').on('click', function(e){
                        e.preventDefault();
                        var item_target = $(this).data('target');
                        // get item index
                        var item_index = $(item_target +' '+$(this).data('photo-target')).parent().index();
                        // get current instance of carousel
                        var carousel_instance = $(this).data('instance');
                        var carousel_instance_data = $(carousel_instance).data('owlCarousel');
                        // fix non explict widths at viewports less than 900.
                        if(carousel_instance_data.width() < 320 & carousel_instance_data.viewport() < 900){
                            carousel_instance_data.onThrottledResize();
                        }
                        // load item from index
                        carousel_instance_data.to(item_index, 100, true);
                        // open modal
                        $(item_target).modal({'show':true});
                        __tnt.trackEvent({'category':'tnt-lightbox','action':'carousel-open', 'label':'article', 'value':'1'});
                        return false;
                    });
                    $('.photo-carousel-caption-toggle').on(__tnt.client.clickEvent, function(e){
                        var item_instance = $(this).data('instance');
                        $(item_instance +' .photo-carousel-caption-toggle').toggleClass('tnt-minus-circle').toggleClass('tnt-plus-circle');
                    });
                }); /*]]>*/</script>
<script>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</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
                var gallery_ad_8f580909_f0b1_508c_9759_b3b7f4474926 = false;
                var gallery_changed_8f580909_f0b1_508c_9759_b3b7f4474926 = false;
                $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926').owlCarousel({
                    items: 1,
                    autoHeight: true,
                    lazyLoad: true,
                    loop: false,
                    navRewind: true,
                    responsiveRefreshRate: 500,
                    
                    
                    dots : false,
                    onTranslated:function(){
                        
                        
                        
                            __tnt.trackEvent($('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926 .photo-container').eq(this._current).data('track-object'));
                        

                        
                        

                        

                    }
                });
                
                var owl = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926');
                owl.on('changed.owl.carousel', function(event) {if( !$('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926 .photo-container').eq(event.item.index).hasClass('engagement-stage') ){
                        setTimeout(function(){
                            $("#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926 .owl-stage-outer").height( $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926 .owl-item.active').height() );
                        }, 300);
                    }
                 
                 
                        try {
            
            var bOnlyDFP = false;
            if( typeof gptAdSlots != 'undefined' ){
                        googletag.cmd.push(function(){
                            googletag.pubads().clear();
                            googletag.pubads().refresh();
                        });}
                if( !bOnlyDFP && typeof TNCMS.AdManager != 'undefined' ){
                        TNCMS.AdManager.refresh({region: ''});}
            } catch(e) {
            __tnt.log(e);
        }

                        
                            var currItem = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926 .photo-container').eq(event.item.index).data('count');
                            if(currItem){
                                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926 .current-count').html(currItem);
                            }
                            $('.modal.in, #carousel-8f580909-f0b1-508c-9759-b3b7f4474926 .item').removeClass('hover');
                        
                        
                });
                
                var photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926 = $('#gallery-items-8f580909-f0b1-508c-9759-b3b7f4474926').data('owlCarousel');
                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926 .photo-carousel-control.left').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926.prev();
                });
                $('#carousel-8f580909-f0b1-508c-9759-b3b7f4474926 .photo-carousel-control.right').on(__tnt.client.clickEvent, function(e){
                    photo_carousel_8f580909_f0b1_508c_9759_b3b7f4474926.next();
                });
            }); /*]]>*/</script>
<script>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</script></body>
</html>